Announcement

Collapse
No announcement yet.

(KISS) Custom Maid 3D 2

Collapse
This is a sticky topic.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Mod Discussion] (KISS) Custom Maid 3D 2

    This is the modding discussion of Custom Maid 3D 2 (CM3D2).

    ==[ Modding tools ]=======================


    ==[ Useful Links ]=======================
    Last edited by Inquisitor; 08-10-2015, 08:19 AM. Reason: Update mod releases link

  • not applicable anymore
    Last edited by rebelgamer; 08-03-2015, 10:40 AM.

    Comment


    • Originally posted by Boboboy View Post
      Well, it's certainly not possible to create new arcs, but you can still create new items for your maid with the help of usagirei's deflarc patch, which you can find here: http://www.hongfire.com/forum/showth...47#post3703147
      Actually, it is possible, but it's not in the code, Its wonky at best:
      Doesn't work for scripts, tjs, and a few other arcs
      Loading a new arc involves further patching of the assembly-csharp, since kiss hardcoded the .arc names
      Can yield undesired results most of the time

      given all that, i decided to only allow reinjecting.

      btw how did you manage to create that second and third entries?
      Signature Space Critical, You can find most of my links and stuff Here now.
      CM3D2: Loaders | Translation | Signboard | Body-Writing
      SBPR: Loaders

      CM3D2 HF Patch (v120.0)
      CM3D2.ToolKit - Pre Release

      Comment


      • I just created menu files with the help of those tools uploaded on uppervolta. Did invest a bit of time to figure out how exactly this system does work. I'm planning to upload a a few mods in a bit, just need to fix some minor issues first.

        Comment


        • If you see one for high heels, let me know. Can't get to uppervolta without my vpn, but my connection keeps cutting it off.

          Comment


          • just curious for the demosaic is it really necessary to have the translation patcher.dll?
            and would it be possible to uninstall these plug-ins cleanly should an emergency event happen
            My Requests(recently updated) , Bishoujo Games Monthly Releases (still without doujins)
            "I am a latent masochist, please rule over me, Mistress"-Croah Vartel[/center]

            Comment


            • @Algester
              As you can see in the requirements you only need the Unity Injector. The Unified Translation Loader isn't needed.
              For the demosaic to work you need:
              ReiPatcher
              Unity Injector
              And of course the Demosaic Patch itself.


              @usagirei I've uploaded the first mod and am working on the second. If you are interested in how to add them as a standalone item, I recommend you to have a look into the files. You can still drop me a message if you have any more questions.

              @rebelgamer
              unfortunately, so far I only found multiple versions of the tool, some eyes and highlights as well as plenty of nude skins (which seem to be deleted from uppervolta a few hours ago).

              Comment


              • Originally posted by rebelgamer View Post
                Ok, for everyone having issues the display panel-user edit problem after using the HF patch, here is what to do. First, go to the unityinjector\config folder, and move the folders there somewhere safe(just in case). Then unzip the contents of the following file into that directory.

                https://mega.co.nz/#!spAmGBYQ!SbROVc...xoJCaMrwcBJX_8
                I'm still getting the error after doing this. Is anything else required?

                Comment


                • Originally posted by SGrimmer View Post
                  I'm still getting the error after doing this. Is anything else required?
                  You need to install version 1.03 correctly. Read the FAQ.

                  Comment


                  • Originally posted by bdsqlsz View Post
                    none。even we can change material menu texture but not model。

                    KISS say in blog that they will release MOD tools in August,maybe in the August middle。
                    Ok, than I will wait till that tools are out, that I can create some mods for this game.

                    Comment


                    • Originally posted by Inquisitor View Post
                      You need to install version 1.03 correctly. Read the FAQ.
                      Oh I downloaded the wrong 1.03 because I'm an idiot and don't have basic reading comprehension. My bad.

                      Comment


                      • I did some testing with the VR patch that was released today, and both UnityInjector and the translation plugin seem to be working just fine. The only thing that's not working is the NoMosaic plugin, but so far I haven't really figured out why.

                        For reference, here's the .ini I used:

                        Code:
                        ### CM3D2VRx64.ini
                        
                        [ReiPatcher]
                        ;Directory to search for Patches
                        PatchesDir=Patches
                        ;Directory to Look for Assemblies to Patch
                        AssembliesDir=%cm3d%\CM3D2VRx64_Data\Managed
                        
                        [Launch]
                        Executable=%cm3d%\CM3D2VRx64.exe
                        Arguments=
                        Directory=%cm3d%
                        
                        ;UnityInjector Patch Entry Point
                        [UnityInjector]
                        Class=SceneLogo
                        Method=Start
                        
                        [Assemblies]
                        Assembly-CSharp=Assembly-CSharp.dll
                        After patching, you'll have to restart the game using "CM3D2VRx64_DirectToRift.exe" to get it to display properly.
                        (`・ω・´)キリッ

                        Comment


                        • Originally posted by Algester View Post
                          just curious for the demosaic is it really necessary to have the translation patcher.dll?
                          and would it be possible to uninstall these plug-ins cleanly should an emergency event happen
                          Originally posted by Boboboy View Post
                          @Algester
                          As you can see in the requirements you only need the Unity Injector. The Unified Translation Loader isn't needed.
                          For the demosaic to work you need:
                          ReiPatcher
                          Unity Injector
                          And of course the Demosaic Patch itself.
                          Demosaic without translation loader? Yes and no.
                          You'll get past the shader mosaic, but alas, the texture also has a mosaic in it, twice the mosaics, twice the fun, amirite?

                          Uninstalling is as simple as rollbacking the .bak files to their original names and pronto, you're clean again.
                          Signature Space Critical, You can find most of my links and stuff Here now.
                          CM3D2: Loaders | Translation | Signboard | Body-Writing
                          SBPR: Loaders

                          CM3D2 HF Patch (v120.0)
                          CM3D2.ToolKit - Pre Release

                          Comment


                          • Originally posted by karmak83 View Post
                            Hi guys, I'm trying to make "Custom Maid 3D 2 Plugin - Dialog Text to Clipboard" work to no avail.
                            I've installed Usagirei loaders and other plugins (translation, Ui etc) and everything works fine.
                            I've installed Dialog Text to Clipboard and patched my game with reipatcher, and according to the log in the console, everything seems fine.
                            But once ingame, text is not pasted to clipboard.
                            My game is using 1.03 and x86 version with appLocal. I use Chiitrans Lite as translator app.
                            Has anybody managed to make this plugin work?
                            When you used ReiPatch to add the plugin for the first time, did it say: "Skipped TextToClipboard" or something similar?
                            It did so for me.

                            It appears the original author, KuroKaze78, has left a tiny nasty bug in his CM3D2.TextToClipboard.Pathcer.dll that made RaiPathcer assume that the plugin has already been applied.

                            I quickly decompiled the DLL and fixed the typo (seriously, it was a matter of adding a single "!" character).
                            Here you can grab the fixed DLL until the original author fixes the issue: Download.

                            Put it in your "Patches" folder, replace the original if prompted and run ReiPatcher again. It should apply the patch successfully.

                            And of course, respect for KuroKaze78 and his neat plugin.

                            Comment


                            • Originally posted by usagirei View Post
                              Demosaic without translation loader? Yes and no.
                              You'll get past the shader mosaic, but alas, the texture also has a mosaic in it, twice the mosaics, twice the fun, amirite?

                              Uninstalling is as simple as rollbacking the .bak files to their original names and pronto, you're clean again.
                              That's right, thought it still looks "feasable". At least it isn't as penetrant as a mosaic. But still then, the translation loader isn't needed to change the texture. If he does use your Deflarc patch, then he could simply replace the texture without editing gamefiles. I am also currently waiting for Menelol's permission to upload a standalone version of his skin texture.

                              Comment


                              • Originally posted by usagirei View Post
                                Strange, looks fine from here, nevertheless you're missing the text translations, when you open the game, the caution screen is still in japanese?
                                If it's not, you just need to download the attachments on the mod release thread, by me and darkpulse, mine provides system translation, his the editor.
                                Check if in the managed directory under D:\HG\CM3D2\CM3D2x64_Data\Managed, there are the files: CM3D2.Translation.dll, ExIni.dll and UnityInjector.dll
                                If the files are there, and the caution is in japanese, then i'm not sure whats happening, so zip the assembly-csharp and send me so i can look at it.
                                Okay, I reinstall the game and patched it to 1.03. Then installed CM3D2_Patching_R3 and now everything seems to be working.
                                "Back in my day all games were pixel art."

                                Comment

                                Working...
                                X