Announcement

Collapse
No announcement yet.

(Illusion) Artificial Girl 3

Collapse
This is a sticky topic.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Mod Support] (Illusion) Artificial Girl 3

    So that the other threads can be used for more constructive posts, we've decided to create a support thread. In this thread you can post your questions/feedback about the various mods out there and hope the creator pays attention. If not, perhaps one of the other friendly people out there will come to your aid.
    Please be as descriptive as possible with your problem. Just posting "I can't get it to work" isn't going to get you a favorable response. If your post is super long because of the problem description, give a brief headline description, and put the bulk of your post inside some SPOILER tags.

    Asleep at the wheel

  • Map Compilation v2.7 was released some days ago....

    As usual, get it here....
    AG3: New Map Compilation / Map addons & extras / Main house paintings
    @HM: Story translation
    AA1: Romanized names

    Comment


    • I got a beautiful blonde elf from the AG3 Character thread. Because her breast is too big, I use the DH Wizzard to reduce its side, but its seem doesn't work at all.
      Anyone help me ?

      Comment


      • Originally posted by sieunhanvietnam View Post
        I got a beautiful blonde elf from the AG3 Character thread. Because her breast is too big, I use the DH Wizzard to reduce its side, but its seem doesn't work at all.
        Anyone help me ?
        Are you aware that the AG3/JS3Make wizard will resize boobs on standard body sizes - try it and see if thats all that is required - if you want any different type of boob changes then you may have to refer to the tutorials or other posts for editing body meshes..


        regards Colin.

        As usual to the HF modding fraturnity... guys [and gals] you are the best.
        Last edited by lensman11; 08-08-2009, 08:53 AM. Reason: spelling error.
        As always please give to all the HF and other modders out there..
        They make it easier for us all to join them on their thrones of knowledge.

        for the girls and for the guys.
        Regards Colin

        Comment


        • Hi again! I was wondering if there are any other custom hairstyles available and if making them is the same way as making/tweaking the clothes/meshes perhaps?

          Comment


          • So after reading this post which explains how pre-expansion mods can break AG3 if applied to the expansion, I figure that's why M100's jewelry mod is causing fatal errors when I try to install it.

            So...
            Am I right?
            And has anyone fixed this mod to work with the expansion or does anyone know how to?

            EDIT:
            Let me simplify this:

            Do the piercing mods work right now with the AG3 expansion [Y/N]?
            Last edited by Yandere; 08-18-2009, 12:23 AM.
            Originally posted by xXJacksXx
            It turns out I was a homo
            It happens to the best of us.

            Comment


            • Don't double post. Edit your first post & delete that second post above me. Thanx.

              Originally posted by StormWing
              Dear Illusion. PLEASE release AG4 already because i'm a proud member of A.S.S (Annoying Awesome Spamming Squad). Period.



              Comment


              • It's not generally considered double posting if you wait a day or more between them, but doesn't look like anyone knows the answers, so I might as well if it floats your boat.
                Originally posted by xXJacksXx
                It turns out I was a homo
                It happens to the best of us.

                Comment


                • New to SB3 and its throwing me so far

                  Greetings.
                  I have just now started getting some useful output from Metaseqia and have been able to edit some shoe meshes as has been my weakness.

                  1/ I had exported the SUN1_flower_shoe meshes [L/R] from ShoesEtAl XX file [thanks to original modder and others] and come up with a high heel scuff..

                  2/ Because I did not expect to change any of the physical base structure of the shoe I did not anticipate any bone or alignment issues. I have also created a new texture to match the simplified shoe structure [which I have done OK previously].

                  3/ I now have the issue of replacing [or removing and re-inserting] the new meshes back into the original XX file or into a new one of my own [renamed from original] but here I come up with big problems.

                  4/ I got the latest version of SB3 utility [thanks Alamar] but I still can not find any option to REPLACE an existing mesh/mqo file.. I did manage to either merge or a hidden replace on the existing mqo files but all the bone entries are missing and I get a terrible smudging of the texture on the front toe cover area which is not in the texture file.

                  5/ I can find no odvious option to add or merge any of the bone entries.

                  6/ When I added the mqo files and tried to select or "add" to the existing structure it keeps referencing the original mqo files and not the new ones for replacement and even mentioned original files I had removed.

                  Can someone point me to a useful tutorial which does just what I want it to - that is REPLACE EXISTING MESH WITH NEW ONE" - sorry for the shouting but many posters [newbies like me] have indicated that the advice that is often given or tutorials graciouly added are directed at people who already have some understanding of what they are doing.

                  [ATTACH]
                  130937
                  [/ATTACH]

                  The 1st image shows the existing bone details - from SUN1_flower_shoe.
                  The right image is of my new mesh showing things to come [I hope] and the problem smudging.
                  The lower image shows the missing bone details.

                  Can someone suggest an easier way to add or replace meshes. I have checked the tutorials but they always seem to go into so much detail I get lost in the terminology etc.
                  As always please give to all the HF and other modders out there..
                  They make it easier for us all to join them on their thrones of knowledge.

                  for the girls and for the guys.
                  Regards Colin

                  Comment


                  • Originally posted by Yandere View Post
                    So after reading this post which explains how pre-expansion mods can break AG3 if applied to the expansion, I figure that's why M100's jewelry mod is causing fatal errors when I try to install it.

                    So...
                    Am I right?
                    And has anyone fixed this mod to work with the expansion or does anyone know how to?

                    EDIT:
                    Let me simplify this:

                    Do the piercing mods work right now with the AG3 expansion [Y/N]?
                    I run AG3+ (Hannari) with M100's piercing mod without trouble, so if there isn't another expansion that's been released, I'd say it's compatible. [Y]

                    However, I didn't-- and don't-- install it as per the tutorial instructions; I took the included files and made it into a Wizzard mod.

                    Here's how I did that:
                    Spoiler

                    M100's package includes two pp files, the new js02_01_03.lst file, textures, and some LST.snip files. This format (lst.snip) doesn't exist in the game, it's just M100's notation for a partial file, but it can be converted into an LST_INSERT compatible file.

                    So-- to make it a Wizzard mod, use the basic Wizzard mod structure.

                    root directory has preview pictures and readme file
                    inside that directory is a folder named AG3. Put the PP files from the mod package in that folder.
                    Inside AG3, put an M_TEX (all caps) folder that has the usual m_tex folders (01_01_01_to, 02_01_02_bo, et c-- in this case it's 01_01_01_to, 11_03_01_gl, and 18_04_03_ea). The original mod also has some textures that have to go in the root game directory, which I stuck in my Wizzard mod's AG3 directory. I'll come back to those.
                    Also in the AG3 directory, put a folder called js3_00_00_00. You'll recognize this as the name of the pp file that stores the LST files. Put the new LST file from M100's package, js02_01_03.lst, in this folder. The mod package should also have included a js02_00_00.lst file, which is the file that has the structure for the tabs in JS3_Make. Two lines have been changed in this file to look like this:
                    Code:
                    2	0	0	3	bra	panties	piercing	0	0	0	0	0
                    3	0	js3_00_00_00.pp	3	%sjs02_01_01.lst	%sjs02_01_02.lst	%sjs02_01_03.lst	0	0	0	0	0
                    Line 2 is the names of the tabs in the "undergarments" section, and line 3 has what PP file their respective LSTs are in, how many tabs/LSTs there are, and then the filenames of the LSTs.
                    Because you'll be replacing the old js02_00_00.lst file, if you've previously installed a mod that changes that file at all, it's going to get overwritten, which can cause fatal errors. (Like if you installed M100's tutorial that adds Sock2 and Glove2 tabs.) I believe technically there's a way to make the change to install this mod and only change these two lines, but I can't remember if I tried that or how successfully it worked.
                    ...Anyway, the js02_00_00.lst file and the js02_01_03.lst file should be in a folder named js3_00_00_00.

                    Finally in the AG3 directory of your mod, have a folder named LST_INSERT (all caps). This is where the lst.snip files go, but with some important changes to turn them into LST_INSERT files. First, copy the contents into .txt files and give them names like "earrings.txt", "finger rings.txt". "piercing connectors.txt" (those are what I used).
                    Right now, the beginning of each line in your file should have a line number, a tab, a zero, a tab, and then four pp file names. You should change them so they have the name of the LST file they belong in (js02_04_03.lst for the earrings, js02_03_01.lst for the finger rings, and js02_01_01.lst for the "linked ring straps"-- these should be the filenames of the lst.snip files) followed by the destination line number and three zeroes, then the .pp filenames. So it'll look like this:
                    Code:
                    js02_04_03.lst	9	0	0	0	js3_m100_acc2.pp	js3_00_03_00.pp	js3_00_03_00.pp	js3_m100_acc2r.pp
                    Remember, those are tabs separating the entries. That's very important!
                    Do that to every line in each file. Don't change anything else. You should have 3 text files when you're done, all in the LST_INSERT folder.

                    So now your mod is all built-- all you have to do is pack it up into a zip or 7z (or rar, but i've never gotten those to work) file, drop it into the mods directory of IllusionWizzard, and install it like normal. It should run just fine. (if not, take a mod that does work, unpack it, and compare your mod to the one that works-- the file structure and the LST_INSERT files-- and fix it where it's different.)

                    After you've run it, those few texture files that you put in the AG3 directory of the mod should have been installed to the /data/ directory of the game; move them up one level to the folder that contains /data/ (it's probably called AG3, JS3, or four japanese characters and a 3). Now you're all done-- fire up Make and test it out!


                    I used this method to install all of M100's mods, as well as making one of my own that added a fourth tab under "undergarments." If it doesn't work or if the instructions or unclear or whatever, you can PM me.

                    Lensman: did you try the "merge" option? It seems counterintuitive but in my observation, what that does is replaces the mesh (if the filenames and mesh object names match) and keeps the bones. The important thing is the object names matching. If you didn't change these when you edited the shoes, there shouldn't be a problem; when you're in the mesh workspace dialogue in SB3Utility, just change the "name of mesh to replace" field to be the same as the mesh you're replacing.

                    That's what I do, and it generally works fine. It's actually the default settings for the program-- if you open/drop an MQO file in SB3U then click on the entry in the "3D" panel at upper left, it should pop up the "workspace" dialogue and all you have to do is check the "name of mesh to replace" field and then hit "auto replace."

                    No idea about the smudging, though. My best guess would be some oddity in the UV map.
                    Last edited by demonezade; 08-19-2009, 12:46 PM. Reason: added a bit
                    My AG3 mods:
                    Sailor Pluto (and clothes) - 5 Slimegirls and clothes - Submissive Miku FIXED and Dominatrix Luka
                    NEW Naughty Jedi Clothes - Saeki and Tohsaka - coming soon: Miku, and assorted awesome things.
                    Lesbian avatar mod: Lillian/Hime from Kaibutsu Oujo -- NPC (regular girl) version with fangs
                    Body Piercings 1 - Body Piercings 2 - Matrix girl - NEW Horny Fanged Demon

                    Comment


                    • Spoiler
                      Spoiler
                      Originally posted by demonezade View Post
                      I run AG3+ (Hannari) with M100's piercing mod without trouble, so if there isn't another expansion that's been released, I'd say it's compatible. [Y]

                      However, I didn't-- and don't-- install it as per the tutorial instructions; I took the included files and made it into a Wizzard mod.

                      Here's how I did that:
                      Spoiler

                      M100's package includes two pp files, the new js02_01_03.lst file, textures, and some LST.snip files. This format (lst.snip) doesn't exist in the game, it's just M100's notation for a partial file, but it can be converted into an LST_INSERT compatible file.

                      So-- to make it a Wizzard mod, use the basic Wizzard mod structure.

                      root directory has preview pictures and readme file
                      inside that directory is a folder named AG3. Put the PP files from the mod package in that folder.
                      Inside AG3, put an M_TEX (all caps) folder that has the usual m_tex folders (01_01_01_to, 02_01_02_bo, et c-- in this case it's 01_01_01_to, 11_03_01_gl, and 18_04_03_ea). The original mod also has some textures that have to go in the root game directory, which I stuck in my Wizzard mod's AG3 directory. I'll come back to those.
                      Also in the AG3 directory, put a folder called js3_00_00_00. You'll recognize this as the name of the pp file that stores the LST files. Put the new LST file from M100's package, js02_01_03.lst, in this folder. The mod package should also have included a js02_00_00.lst file, which is the file that has the structure for the tabs in JS3_Make. Two lines have been changed in this file to look like this:
                      Code:
                      2    0    0    3    bra    panties    piercing    0    0    0    0    0
                      3    0    js3_00_00_00.pp    3    %sjs02_01_01.lst    %sjs02_01_02.lst    %sjs02_01_03.lst    0    0    0    0    0
                      Line 2 is the names of the tabs in the "undergarments" section, and line 3 has what PP file their respective LSTs are in, how many tabs/LSTs there are, and then the filenames of the LSTs.
                      Because you'll be replacing the old js02_00_00.lst file, if you've previously installed a mod that changes that file at all, it's going to get overwritten, which can cause fatal errors. (Like if you installed M100's tutorial that adds Sock2 and Glove2 tabs.) I believe technically there's a way to make the change to install this mod and only change these two lines, but I can't remember if I tried that or how successfully it worked.
                      ...Anyway, the js02_00_00.lst file and the js02_01_03.lst file should be in a folder named js3_00_00_00.

                      Finally in the AG3 directory of your mod, have a folder named LST_INSERT (all caps). This is where the lst.snip files go, but with some important changes to turn them into LST_INSERT files. First, copy the contents into .txt files and give them names like "earrings.txt", "finger rings.txt". "piercing connectors.txt" (those are what I used).
                      Right now, the beginning of each line in your file should have a line number, a tab, a zero, a tab, and then four pp file names. You should change them so they have the name of the LST file they belong in (js02_04_03.lst for the earrings, js02_03_01.lst for the finger rings, and js02_01_01.lst for the "linked ring straps"-- these should be the filenames of the lst.snip files) followed by the destination line number and three zeroes, then the .pp filenames. So it'll look like this:
                      Code:
                      js02_04_03.lst    9    0    0    0    js3_m100_acc2.pp    js3_00_03_00.pp    js3_00_03_00.pp    js3_m100_acc2r.pp
                      Remember, those are tabs separating the entries. That's very important!
                      Do that to every line in each file. Don't change anything else. You should have 3 text files when you're done, all in the LST_INSERT folder.

                      So now your mod is all built-- all you have to do is pack it up into a zip or 7z (or rar, but i've never gotten those to work) file, drop it into the mods directory of IllusionWizzard, and install it like normal. It should run just fine. (if not, take a mod that does work, unpack it, and compare your mod to the one that works-- the file structure and the LST_INSERT files-- and fix it where it's different.)

                      After you've run it, those few texture files that you put in the AG3 directory of the mod should have been installed to the /data/ directory of the game; move them up one level to the folder that contains /data/ (it's probably called AG3, JS3, or four japanese characters and a 3). Now you're all done-- fire up Make and test it out!


                      I used this method to install all of M100's mods, as well as making one of my own that added a fourth tab under "undergarments." If it doesn't work or if the instructions or unclear or whatever, you can PM me.
                      Originally posted by demonezade View Post
                      Lensman: did you try the "merge" option? It seems counterintuitive but in my observation, what that does is replaces the mesh (if the filenames and mesh object names match) and keeps the bones. The important thing is the object names matching. If you didn't change these when you edited the shoes, there shouldn't be a problem; when you're in the mesh workspace dialogue in SB3Utility, just change the "name of mesh to replace" field to be the same as the mesh you're replacing.

                      That's what I do, and it generally works fine. It's actually the default settings for the program-- if you open/drop an MQO file in SB3U then click on the entry in the "3D" panel at upper left, it should pop up the "workspace" dialogue and all you have to do is check the "name of mesh to replace" field and then hit "auto replace."
                      Originally posted by demonezade View Post
                      No idea about the smudging, though. My best guess would be some oddity in the UV map.
                      Thanks for the prompt reply.
                      Yes I did try the replace option but I have seem references to "drag/drop" on SB3 utility before and still lost the bones. When I did somehow manage to get the mqo files back into the XX and in a usable state when I added the shoes to a fashion set they were stuck 10 inches in front of the girls foot and did not seem to move properly with her... I assume that is because of the missing bone linkages....

                      Edit: Thanks for the advice - I have now managed to update the original meshes with my new ones keeping the bone connections. I had some fiddling with shoe orientation to keep the foot in the right place on the new shoe sole but all came OK in the end.

                      Next step is to solve the smudging texture problem. I will detail that in a new post - thanks...
                      Last edited by lensman11; 08-20-2009, 05:15 AM.
                      As always please give to all the HF and other modders out there..
                      They make it easier for us all to join them on their thrones of knowledge.

                      for the girls and for the guys.
                      Regards Colin

                      Comment


                      • Greetings modders..
                        From my request post below you will see I did progress further but I still have 2 problems.
                        1/ Is the smudging is still appearing directly from the mesh when loaded into SB3 which is not showing in the Metasequia mqo files.
                        Note: The smudge on the inner sole area is intentional [ looks like wear].

                        The attachment image below shows on the left [SB3 utility display] and on the right [Metasequia].

                        Can anyone suggest what may be doing this as its not only messing up the mesh display but screws up the textures when applied afterwards also. I have checked the UV file but I don't have a clue what I am looking at.. I will upload the XX file if someone thinks they can assist by editing it further..

                        I am really looking forward to progressing further on this as other posters have already noted an absence of shoes and boots to which I have a real weakness and would like to continue with a large selection of footwear items to choose from.

                        The additional attachments below will show examples of what I have in store to try creating in the near future.

                        Spoiler

                        Click image for larger version

Name:	4__Heel_Sandal_4a1732a09cb89.jpg
Views:	1
Size:	378.6 KB
ID:	4814451


                        Please help and make my fantasy come true..
                        Last edited by lensman11; 08-20-2009, 06:03 AM. Reason: Conserving space.
                        As always please give to all the HF and other modders out there..
                        They make it easier for us all to join them on their thrones of knowledge.

                        for the girls and for the guys.
                        Regards Colin

                        Comment


                        • Originally posted by lensman11 View Post
                          Edit: Thanks for the advice - I have now managed to update the original meshes with my new ones keeping the bone connections. I had some fiddling with shoe orientation to keep the foot in the right place on the new shoe sole but all came OK in the end.
                          As far as I can tell, the new mesh keeps bone connections only if it goes through the same coordinates as where the bones connected on the old mesh (ie, if you start with a glove and import a pinky finger ring, it only keeps the bones in the pinky finger) so if you moved the sole around, that might have been part of your problem.
                          My AG3 mods:
                          Sailor Pluto (and clothes) - 5 Slimegirls and clothes - Submissive Miku FIXED and Dominatrix Luka
                          NEW Naughty Jedi Clothes - Saeki and Tohsaka - coming soon: Miku, and assorted awesome things.
                          Lesbian avatar mod: Lillian/Hime from Kaibutsu Oujo -- NPC (regular girl) version with fangs
                          Body Piercings 1 - Body Piercings 2 - Matrix girl - NEW Horny Fanged Demon

                          Comment


                          • Originally posted by lensman11 View Post
                            Greetings modders..
                            From my request post below you will see I did progress further but I still have 2 problems.
                            1/ Is the smudging is still appearing directly from the mesh when loaded into SB3 which is not showing in the Metasequia mqo files.
                            Note: The smudge on the inner sole area is intentional [ looks like wear].

                            Please help and make my fantasy come true..

                            does the smudge show up in MAKE? if it don't, problem solved.

                            how big is the texture map, I know Metasequia will 'round' to the nearest color if the texture map is small (256x256). So fine details will not show up, hence the smudging.

                            Comment


                            • Originally posted by DillDoe View Post
                              does the smudge show up in MAKE? if it don't, problem solved.

                              how big is the texture map, I know Metasequia will 'round' to the nearest color if the texture map is small (256x256). So fine details will not show up, hence the smudging.
                              Thanks for the reply.
                              The texture started off as 512 X 512 and aslo 1024 X 1024 for detail work.

                              The smudge shows up on a raw mesh imported in SB3 even if I use a blanked out the texture [full white] - any new texture applied shows the smudging under the texture.. I am not even game to try alpha channels in TGA files yet.. Using the mesh via Make and the smudging appears also any edges are so ragged as to make the whole item look very shabby [like an old but comfertable shoe] ???? ..

                              Edit: Have added the xx file to allow testing of the included mqo files.
                              Can anyone else assist with a solution to this. ???
                              Spoiler



                              Thanks in anticipation..
                              Last edited by lensman11; 08-23-2009, 01:37 AM. Reason: Adding sample files for upload
                              As always please give to all the HF and other modders out there..
                              They make it easier for us all to join them on their thrones of knowledge.

                              for the girls and for the guys.
                              Regards Colin

                              Comment


                              • I know this is going to sound weird. but there was a korean modder that made a full body suit (skin tight) good mod... and since i was bored i tought to make some busstier basic textures.

                                but there was something bugging me about it. since it was a 2 part mod.
                                - it used the high cut swimsuit shape and textures in the panty slot as the base
                                -and a bra slot for the sleeves and legs

                                so if i wanted a bustier i had to make the panties included or leave it half naked (wich bothered me if i wanted to use different panties.

                                so i gave up for a long time. but now im bored again.
                                but i want to change the main to a bra sloth so i can use diff panties.

                                but i gotta say im still reading (just went about 10 pages and getting bored lol)
                                how can i change it to another slot?

                                thanks in advance

                                P.S. i will still keep reading the thread but if the solution comes faster id gladly accept it

                                Edit: seems i will have my workload increased so again i will have to drop the idea <sigh> anyway thanks
                                Last edited by elfdrow; 08-21-2009, 01:20 PM.

                                Comment

                                Working...
                                X