Announcement

Collapse
No announcement yet.

AMD CRASH FIX FOR Radeon HD Series

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Miscellaneous] AMD CRASH FIX FOR Radeon HD Series

    --TO MODERATORS-----------------------------------------------------------------------------------------------
    I'm reposting information I put into the discussion of the game from here I'm only reposting here because I did not want the useful information to be drowned out in the discussion thread. If this does not belong here or if it presents a problem feel free to delete it from here. I'm sorry for any inconvenience.
    ------------------------------------------------------------------------------------------------------------------

    TO ALL AMD USERS EXPERIENCING CRASHES IN EDITOR OR GAMEPLAY~!!!

    KISS HAS OFFICIALLY ADDRESSED THIS PROBLEM. THEIR SOLUTION IS AS FOLLOWS;
    Run CM3D2.exe Launcher! Make sure your game/launcher is up to date~! Then toggle the following options as per the image below~!

    Spoiler


    Launch your game now via the normal x86 executable~!

    If that for some reason doesn't work then you can try one of the options below to try and fix your problem~!

    Testing on an older rig using an AMD HD Radeon 6700 card that was experiencing crashes using the unity command line argument "-force-feature-level-10-0" in the shortcut for launching one's game does indeed seem to fix said crash problem. Switching nipple textures and skin textures now behaves properly and using the daytime activity "Spa" which would normally crash the game now functions properly.

    If not using applocale or NTLEA your shortcut should look like this;
    *:\KISS\CM3D2\CM3D2x86.exe -force-feature-level-10-0
    or
    *:\KISS\CM3D2\CM3D2x64.exe -force-feature-level-10-0

    So remember if you are using applocale your shortcut should look like this;
    +:\Windows\AppPatch\AppLoc.exe "*:\KISS\CM3D2\CM3D2x86.exe" "-force-feature-level-10-0" "/L0411"
    or
    +:\Windows\AppPatch\AppLoc.exe "*:\KISS\CM3D2\CM3D2x64.exe" "-force-feature-level-10-0" "/L0411"

    For those using NTLEA it should like like this;
    &:\KISS\CM3D2\NTLEA\x86\ntleas.exe "*:\KISS\CM3D2\CM3D2x86.exe" "C932" "L0411" "A-force-feature-level-10-0"
    or
    &:\KISS\CM3D2\NTLEA\x64\ntleas.exe "*:\KISS\CM3D2\CM3D2x64.exe" "C932" "L0411" "A-force-feature-level-10-0"

    The * is the letter for the drive the game resides on and the + is the letter for the drive where applocale is located. The & is for the letter of the drive NTLEA is on.

    For instance if applocale was in drive C and the game was in drive L it would look like;

    C:\Windows\AppPatch\AppLoc.exe "L:\KISS\CM3D2\CM3D2x86.exe" "-force-feature-level-10-0" "/L0411"

    Likewise the NTLEA path above was assuming it was installed via the HF Patch where the game is thus it would look like;

    L:\KISS\CM3D2\NTLEA\x64\ntleas.exe "L:\KISS\CM3D2\CM3D2x64.exe" "C932" "L0411" "A-force-feature-level-10-0"

    Were it in a custom location you would need to alter the first bit to match it's location. For example assuming NTLEA was in E:\NTLEA;

    E:\NTLEA\x64\ntleas.exe "L:\KISS\CM3D2\CM3D2x64.exe" "C932" "L1041" "A-force-feature-level-10-0"

    For Locale Emulator the instructions are a bit different. Rather than editing a shortcut you'll need to alter the Application Profile for the game. Do this like so;

    1-Right click on the CM3D2x86.exe and highlight Locale Emulator then from the dropdown menu select Modify Application Profile.

    2-In the top box paste the following -force-feature-level-10-0

    3-Save the profile.

    4-For subsequent uses just right click CM3D2x86.exe and highlight Locale Emulator then from the dropdown menu select Run With Application Profile.

    For a visual guide to setting this up for Locale Emulator check out DDRPTP's post on this page http://www.hongfire.com/forum/showth...06#post3720306

    Here's the proof make note of the activity "spa" in the background;
    Spoiler


    This was on a Windows 7 Ultimate x64 OS.

    Hopefully this can help other AMD users experiencing this unwanted crash behavior to fix it. Kudos to tsumiyarin for indicating this method. Likewise kudos to DDRPTP for the Locale Emulator information as well as borrowing your pic for the KISS official explanation.
    Attached Files
    Last edited by Oniraizzo; 10-28-2015, 11:14 PM. Reason: ~Yet Another Info Update~Pic Fix~

  • #2
    Thanks for the FIX works great on my AMD Radeon HD 5770 using Windows 8.1 x64

    And... sorry with my english xDDD
    щ(ಠ益ಠщ) щ(ಠ益ಠщ) SORRY WITH MY ENGLISH!!!! щ(ಠ益ಠщ) щ(ಠ益ಠщ)
    (ノಠ益ಠ)ノ彡┻━┻ I HATE MYSELF!!! xD (ノಠ益ಠ)ノ彡┻━┻

    Comment


    • #3
      AMD Radeon HD 7670M using Windows 8.1 x64
      It Work *-* <3 Thanks
      [I'm sorry for my English,in Italy we have only Pizzas :3 ]

      Se hai bisogno di una mano con Custom Maid,chiedi pure :3

      Comment


      • #4
        how did you added that man texture i dont want a ghost in my game

        Comment


        • #5
          @play9q2

          Oh that "man" isn't my character it's actually part of the spa activity. It seems you have a professional come to massage your maid and whatnot.

          Comment


          • #6
            Works like a charm, thanks.

            Comment


            • #7
              deym. i'm about to give up on this game because of these error. thanks man. it does work.

              ok. didn't really mean to.

              Comment


              • #8
                Thank you man you are saint.

                Comment


                • #9
                  I'm having some trouble getting this fix to work. I right click the shortcut and add C:\KISS\CM3D2\CM3D2x86.exe -force-feature-level-10-0 to the target. Then when I try the spa it still crashes. What am I missing? I'm using the HF pApploc and I am not using NTLEA.

                  Comment


                  • #10
                    I'm new test

                    -force-d3d11 -force-feature-level-10-1 no error pic good
                    Spoiler



                    -force-d3d11 -force-feature-level-9-3 no error pic bad
                    Spoiler
                    Last edited by tsumiyarin; 08-29-2015, 10:26 AM.

                    Comment


                    • #11
                      @SolidSnake16

                      Hmm your problem is quite perplexing. What model is your graphics card? As tsumiyarin in the post above indicates you can try -force-feature-level-10-1 to basically run the game with a slightly more updated feature set. If that does not work I'd suggest making sure you have the most up to date drivers for your card and leaving most of the settings in your cards 3D Graphic configuration to "Use application settings" to ensure maximum compatability. Likewise if you are using CCC you can check in the performance tab under AMD Overdrive to see current heat on the GPU to make sure your not overheating (I doubt you are but better safe than sorry~!) or use any software you prefer to monitor heat levels. As an aside the command -force-d3d11 is unecessary when using -force-feature-level-10-0 or -force-feature-level-10-1 as this command basically tells the game to run with with d3d10 insrtuction set thus overriding the initial -force-d3d11. This is demonstrated by displaying d3d information while in game via mods like reshaders as seen here;

                      Spoiler


                      Anyway I hope this helps with your problem. Chime back in if you need anything~!

                      Comment


                      • #12
                        i'm sorry for -force-d3d11 in test run on sweetfx show d3d10 T^T.

                        Comment


                        • #13
                          No worries~! We are all learning new stuff all the time~! At least you are running tests and that helps other people so be glad for the efforts you've made~! ^_^

                          Comment


                          • #14
                            It is an AMD Radeon 7570. It is up-to-date, and using application settings. No issues with overheating. Still crashing during character creation and gameplay.

                            Comment


                            • #15
                              @SolidSnake16

                              Try this. Try using -force-feature-level-10-1 if you haven't already. If that fails try re-editing your shortcut with the following;

                              I forgot to ask what OS you were using but it should be basically the same for win7/8/10

                              At the target line erase what's there and paste this in (If some of this seems redundant please just bear with me.);

                              C:\Windows\AppPatch\AppLoc.exe "C:\KISS\CM3D2\CM3D2x86.exe" "-force-feature-level-10-0" "/L0411"

                              Under the compatability tab select Windows 7 and check the box for Run this Program as an Administrator.

                              After applying all that to the shorctut double click it and see if that works. If that doesn't work then please in your reply put your OS and a screenshot of your shorctut's properties. I know this is frustrating but at this point I'm simply trying to eliminate possible errors in the process to hopefully track down where the problem lies.

                              Comment

                              Working...
                              X